That’s totally ridiculous… Eclipse Luna SR1 (4.4.1) has a totally broken auto-complete (And it’s been broken for several months). The only way to fix it is it to install an unreleased maintenance build of Eclipse Java Development Tools plugin from here:
http://download.eclipse.org/eclipse/downloads/drops4/M20150121-0900/

Advertisements